Your name or email adress:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Converter Box Not Working


    This is a discussion on Converter Box Not Working within the Converter Boxes and ATSC Tuners forums, part of the Over-the-Air (Antenna TV) category.

    Results 1 to 11 of 11
    1. #1
      DTVUSA Rookie
      Join Date
      Jun 2009
      Posts
      3

      Default

      I need some major help, maybe mental too because I can't connect this box to my TV right. MY TV has 1 port on the back which looks like where cable goes (cable like a cable company that I used to have) and I connected the wire in there and to my converter and set my TV to channel 4 but all I see is snow. Frustration! Again, everything is connected, and TV is set to 4. Help!

    2. #2
      DTVUSA Member
      Join Date
      Mar 2009
      Location
      Kamas, Utah
      Posts
      887

      Default

      Quote Originally Posted by Cherry View Post
      I need some major help, maybe mental too because I can't connect this box to my TV right. MY TV has 1 port on the back which looks like where cable goes (cable like a cable company that I used to have) and I connected the wire in there and to my converter and set my TV to channel 4 but all I see is snow. Frustration! Again, everything is connected, and TV is set to 4. Help!
      Welcome to the DTVUSA Forum. The TV is set to 4. Is the converter output set to 4? Did you see anything on the TV screen at all? If you see a menu on the screen then your good. Next you'll do a scan for channels.

    3. #3
      DTVUSA Rookie
      Join Date
      Jun 2009
      Posts
      3
      Thread Starter

      Default

      I can't see the menu at all. The TV is set to 4, and the box is plugged to the TV and set to channel 4. I can't do a scan because all I see is snow.

    4. #4
      DTVUSA Member
      Join Date
      Apr 2009
      Location
      East Coast
      Posts
      48

      Default

      Lets use process of elimination

      1. Is your coax cable running from the back of your converter box out of the "RF Out"?

      2. Is the other side of your coax cable running to your TV to "RF In" or "Antenna In"?

      3. Confirm that your TV is set to channel 4

      4. Plug your antenna into the back of your converter box in the input that's labeled "RF In"

      5. Confirm that the back of your converter box doesn't have a dip switch that needs to be set to channel 4, if it does, set that switch to 4.

      6. Make sure that both the TV and converter boxes are powered on. Most converter boxes require you to press the power button first.

      See this thread if you would like to see a video demo of a converter box installation: http://www.dtvusaforum.com/converter...ox-videos.html

    5. #5
      DTVUSA Member
      Join Date
      Jan 2009
      Location
      Rossmoor, Sunny Southern California
      Posts
      330

      Default

      Have you tried Channel 3? Some boxes are set to default on Channel 3, some do on 4.

    6. #6
      Administrator
      Join Date
      Aug 2008
      Location
      Phoenix, Arizona
      Posts
      2,268
      Blog Entries
      37

      Default

      Quote Originally Posted by Cherry View Post
      I can't see the menu at all. The TV is set to 4, and the box is plugged to the TV and set to channel 4. I can't do a scan because all I see is snow.
      Here is another video from YouTube on how to connect a converter box (courtesy of orjames7)

      [YOUTUBE]http://www.youtube.com/watch?v=ViKzzQCsN3E[/YOUTUBE]

    7. #7
      DTVUSA Rookie
      Join Date
      Jun 2009
      Posts
      3
      Thread Starter

      Default

      Quote Originally Posted by Boo-Ray View Post
      Lets use process of elimination

      1. Is your coax cable running from the back of your converter box out of the "RF Out"?

      2. Is the other side of your coax cable running to your TV to "RF In" or "Antenna In"?

      3. Confirm that your TV is set to channel 4

      4. Plug your antenna into the back of your converter box in the input that's labeled "RF In"

      5. Confirm that the back of your converter box doesn't have a dip switch that needs to be set to channel 4, if it does, set that switch to 4.

      6. Make sure that both the TV and converter boxes are powered on. Most converter boxes require you to press the power button first.

      See this thread if you would like to see a video demo of a converter box installation: http://www.dtvusaforum.com/converter...ox-videos.html
      I'm a goofball. I had the antenna wire mixed up with the converter box wire. I had RF Out going to my antenna. It's connected and I'm scanning the channels right now as I type this. Thank you so much.

    8. #8
      DTVUSA Member
      Join Date
      Mar 2009
      Location
      Kamas, Utah
      Posts
      887

      Default

      Quote Originally Posted by Cherry View Post
      I'm a goofball. I had the antenna wire mixed up with the converter box wire. I had RF Out going to my antenna. It's connected and I'm scanning the channels right now as I type this. Thank you so much.
      Enjoy your new DTV. Come back and post in the DTVUSA Forums, anytime.

    9. #9
      DTVUSA Rookie
      Join Date
      Jun 2009
      Posts
      1

      Default

      Hi I have a problem... I set up everything teh coverter box antenna everything! and I got the welcome screen but its frozen it doesnt let me do anything after the language! is something wrong with the box?? Several times I unpluged everything and started again but still is the same thing!! Can someone help me?

    10. #10
      Contributor
      Join Date
      Nov 2008
      Location
      Boston, MA market
      Posts
      625

      Default

      Quote Originally Posted by lacangrydepr View Post
      Hi I have a problem... I set up everything teh coverter box antenna everything! and I got the welcome screen but its frozen it doesnt let me do anything after the language! is something wrong with the box?? Several times I unpluged everything and started again but still is the same thing!! Can someone help me?
      Did you get to the part where you scan for channels?

      and what model/brand box is this?

    11. #11
      DTVUSA Member
      Join Date
      Feb 2009
      Location
      Owensboro, Kentucky
      Posts
      1,473

      Default

      Did you install the batteries in the remote? sometimes also the ones shipped with the box are cheap crap batteries. one of my boxes had the included remote batteries leaking acid. get some real batteries.

     

    Related Topics and Posts

    1. Converter Box Not Working
      By CYNTHIA in forum Converter Boxes and ATSC Tuners
      Replies: 2
      Last Post: 11-04-2009, 02:58 PM
    2. Grin not working
      By bicker in forum Forum Help Zone
      Replies: 6
      Last Post: 08-26-2009, 07:38 AM
    3. DTV Box stopped working
      By tdepra in forum Converter Boxes and ATSC Tuners
      Replies: 2
      Last Post: 02-09-2009, 04:36 PM
    4. Magnavox DVR not working
      By Lucinda in forum Introduce Yourself
      Replies: 0
      Last Post: 10-22-2008, 06:39 PM

    Quick Reply Quick Reply


    Click here to log in

    What state is the city of Los Angeles located in? (Answer this question correctly, it is used to stop spammers)

    Tags for this Thread

    Share this Post

    Join DTVUSAForum

    The leading television and technology community discussion site, join today!

    DTV USA Forum is the best source of television
    and technology troubleshooting advice from a community of experts and members.

    Back to top