5 months of U-Verse Never working, paying full price - DirecTV

#1
I suppose my question is to the AT&T company employees who could never help me over the past five months of my service.

I moved into a home divided into multiple units in September of 2016. Upon the first day of my internet and U-verse installation, the connection stream lasted around 15 minutes maximum before it was lost. I am being literal in the time sequences. Surfing the internet, watching Netflix, watching the world series --which cut out in the 10th inning, *talking online to AT&T customer service representatives about my issue and losing our conversation in its entirety*, or participating in any act that involved the service I was paying for.

Thus, began the five-month battle of attempting to fix my service. I do not remember the number of techs sent to my residence (5 or 6), and 2 techs sent to perform work outside my home. On countless occasions, I have called customer service and chatted online with representatives...each time I did this it was astounding to me that I had to repeat to them my issue which had been an issue for months at a time. Tech support tried various things to fix our connection. From new wiring, new equipment, and other measures I do not understand but was under the supervision of my husband. No tech was helpful; no customer service agent was helpful. No time I spent trying to resolve my issue was helpful. No bill I paid was for a service I was receiving. I know this may sound first world, but when your connection goes down EVERY 15 minutes when you are working on your laptop or watching a movie you paid for...for $150 a month, your frustration would set in also. Techs would even ask us to not call back and report the same issue, for they would get in trouble for not fixing it... I made an appointment online one time for a supervisor to call me...that never happened...Each time we had a tech come out (one a month, sometimes two a month) we called back to report that we were having the same issue. Nothing happened. So this was a perpetual cycle of techs coming out, us calling, nothing happening, then calling to send a new tech out, paying a bill for something we didn't get, and repeat!

AT&T Customer Service always answered my calls and chat questions...as in there was responsive dialogue, but they never helped me understand why I was paying for something that they couldn't fix. They did not care if I wasn’t getting sufficient service...as long as they were getting money. When I say my service went out every 15 minutes, I mean I have watched more of the troubleshoot screen than any movie, show, or sports game in five months...if only I had known this when I was signing up.

After five months of calling/texting techs directly, speaking with customer service, and throwing away my time and money-- I can honestly say I have never felt so idiotic for giving a company 5 months and STILL PAYING THEM FULL PRICE for them to resolve an issue with their service. I am astounded by this. What is MORE astounding to me, is that I have to pay an early cancellation fee for something that never worked...I truly feel as if I am being taken advantage of for my money. I have no problem spending my money for a service that works. Even minor technical errors I understand because I know I do not understand the big picture, but not being able to watch TV for 15 minutes or applying for a volunteer position online and losing all of it because I lost connection....is more than a glitch. It is a problem.

Gratitude to all the techs who were professional in their approach to help me resolve my issue. However, this is a small list of people on a long list of those contacted. Customer service goes a long way. However, it is hard to consider myself a customer in this relationship because I never really used the company's services...they really just used me.


This question, "5 months of U-Verse Never working, paying full price," is about DirecTV channels, programming, equipment, and sports.
 
Top