Black screen on TV

#1
Connected the converter last night and turned the TV on and I still show a black screen. I followed the instructions perfectly and connected the cords correctly and I have no idea what I did wrong! Please help at your earliest convenience, I have no TV right now but I'll be traveling to my daughter's house for the weekend anyway.
 

divxhacker

DTVUSA Member
#3
Connected the converter last night and turned the TV on and I still show a black screen.
Has the converter been turned on?

If you are connected through the RCA connections, have yo made sure the video connection is in the correct connector? You might need to rotate the connector, there could be grime in there, which might not let the picture through.
 

1inxs

DTVUSA Member
#4
You need to switch the TV to the correct input. If your cables are connected to input 1 switch the TV to input 1. If the cables are connected to input 2 switch the TV to input 2 and so on.
Connected the converter last night and turned the TV on and I still show a black screen. I followed the instructions perfectly and connected the cords correctly and I have no idea what I did wrong! Please help at your earliest convenience, I have no TV right now but I'll be traveling to my daughter's house for the weekend anyway.
 
#5
Now some converters if using A/V input may NOT have it enabled out of the box. that means you still need to connect it to an RF input and then select 'A/V' or whatever else it calls it. composite is another name for it in a menu. the Dish DTVPal+ has that option when first going through the setup wizard. in fact that box requires RF input initially until fully set up so it won't work on A/V out out of the box.

Of course, if the box isn't powered on (some show a LED lamp lit even when off or one which changes colors but still gives the impression it turned on already; why not just a bright green LED which is either on or off? saves confusion) you won't get much.
 

Piggie

Super Moderator
#6
Connected the converter last night and turned the TV on and I still show a black screen. I followed the instructions perfectly and connected the cords correctly and I have no idea what I did wrong! Please help at your earliest convenience, I have no TV right now but I'll be traveling to my daughter's house for the weekend anyway.
Did you even see a menu from the converter box on the TV? That will tell you it's connected right to the TV.

1) Make sure the converter box is on. most have a LED that lights up.
2) Use the cable with the sharp ends, make sure your TV is on Ch3.

You should see a menu.

Can you get that far?
 
#7
What brand of converter box? some have LEDs that are always lit but change color when on/off. the Insignia and Zenith boxes have red LEDs when off and bright blue when on. some times it's confusing to those (like me) who associate power with the light being on. i don't know why they decided they must change colors instead. i like to have a box not have a bright light in my face when off myself.

If it is on, but you're not getting the 'Welcome' screen or wizard or other set-up menu, then either your TV isn't on channel 3 or 4 (or the wrong one, some boxes have a toggle switch in rear to select it and you may need to go up or down one channel) or to select AV mode on some TVs there's no 'Input/Video Select' button but you tune to channel '00' and it then shows 'L1 (REAR) or L2 (Front) or something. finding A/V mode on TVs is always fun to figure out but can have so many ways of going at it it's crazy.
 
Last edited:

Similar threads

Top