Defective new Hitron E31 N2V1 modem? - Time Warner Internet

#1
This question is about "Defective new Hitron E31 N2V1 modem?", with Time Warner Cable internet and apps. Hi all,

I've had Spectrum at my home (Portland, ME) for two years and everything worked fine until I decided to upgrade to the new 400 Mbps on Friday.

The technician came to replace my old modem with a Hitron E31 N2V1 for the upgrade. Everything worked fine that day (Friday) and Saturday morning. When I came home in the evening on Saturday and today (Sunday) all day, my downloads don't go above 20-30 Mbps.

I restarted the modem, my wireless router (eero 2nd gen.), connected directly a laptop, same results. I called Spectrum technical support and while they said that the modem looks to be functioning within the correct parameters, they reprovisioned it and the download speed worked again to be at 400 Mbps. .... only for an hour or so. I am now again stuck with 20-30 Mbps.

Is there a chance that the modem is defective? I didn't change anything in my home setup in two years. And the fact that after reprovisioning the modem the downloads worked briefly, but then crapped out again, makes me think something's fishy with the modem.

Planning to call Spectrum again tomorrow, but any input or feedback would help!

Thanks!

Defective new Hitron E31 N2V1 modem??
 
Top