Mysteriously, Xfinity Stream app playback is now working (?) - XFinity

Hi everyone,

Background: In ~October 2020 I posted about playback not working after upgrading my iPad to OS 14.0.1 - I kept getting the TVAPP-00300 error message. Curiously, it worked when I connected to WiFi via a local Xfinity hotspot instead of my home Xfinity WiFi. I called up customer service and spent hours with them trying many things (them doing something there, resetting my gateway, logging out and in, etc). I got transferred many times (ugh!!), eventually to the programmers, where it was determined the problem was in my gateway, not an incompatibility with OS 14.0.1. In the meantime I've been streaming tv on the Safari browser (not as good as the app).

Today I was in the Stream app looking at the listings, and accidentally hit the "watch" button. Lo and behold it worked! Just a few days ago I did the same thing and it didn't work, as has been the case since October (I always got error TVAPP-00300).

So what mysterious thing did they do to make it work?? Did they secretly reset my gateway? Make an adjustment to my account to fix whatever had been blocking playback only when using the app via home WiFi? Did they discover there WAS an incompatibility with Apple iPad OS 14.x after all (which was my original suspicion)? I'm very glad it's now working, but unhappy they didn't inform me they found the problem. My opinion of Xfinity customer support is down a few points. And I hope it still works tomorrow.


This question, "Mysteriously, Xfinity Stream app playback is now working (?)," is about XFinity-Comcast TV Television Apps.

For other news regarding Mysteriously, Xfinity Stream app playback is now working (?), and XFinity - Comcast Television Apps, see our recommended stories below.

Similar threads