Spectrum TV App won't load - TWC TV and Apps

#1
I have an android phone. The app worked fine until a few days ago. It no longer loads at home or on the go. The error message I receive is:

"We're sorry, something didn't quite work right. Please try later. DGE-1001. "

It's several days later and I still get that message. I have uninstalled and reinstall the app. Same message. I am on Android 6.01.


This question is about "Spectrum TV App won't load", with Time Warner Cable TV and apps.
 
G

Guest

Guest
#4
same problem, Tampa bay

I have been getting the same message since last night - July 16, at least 8:55pm. You have to call them and tell them because they don't think there is a problem until it's "trending." I kid you not. So, everyone having the problem has to report it.

At least I now know the tech support department you want is "internet" even though the app in TV.

Also if you have your own router, but their modem, they will tell you they can't help you, which is garbage. Just get them to report the issue anyway. Apparentlt they don't know it's down till people complain.
 
G

Gene Scott

Guest
#6
This is what happened to me. Charter changed my login name to my charter email name, e.g. firstmlast@charter.net. Use your Charter email and your password. If that does not work, call Charter and ask them to change your password.
 
Top