Upgraded to new modem and now slower speed or dropped connection on one laptop - Time Warner Internet

#1
This question is about "Upgraded to new modem and now slower speed or dropped connection on one laptop", with Time Warner Cable internet and apps. Hi there -- I upgraded from one customer owned modem (Motorola SB6141) to another (Motorola MB7420).



Modem is connected to Apple Airport Extreme. That appears fine.



I've got 2 laptops running fine and getting speeds of 70/5 (I have a 50/5) plan. My iPhone gets the same speeds.



I've got a 3rd laptop that was working fine with old modem, but connectivity either cuts out all together, or slows to a crawl (1 / 5). I've reset modem (both turning everything off and via the Spectrum website option to "Reset My Modem" under My account > Trouble Shoot > Modem



After I've turned it off, I occasionally get higher speeds, but am currently getting about 20/5 on the laptop and the others are getting 70/5



This laptop works great on my Spectrum internet at my office where I'm getting speeds of 200 or 300. So I don't think it's the laptop.



What do you suggest I do next to try to figure this out?



I noticed others with this modem have posted error logs. In the past I've been able to access the modem (192.168.100.1) -- but I'm getting an error message while doing so:



safari can't open page because server unexpectedly dropped connection.



-- though I can access it from my phone (on wifi) or from another laptop.



That's strange, no? Any suggestions?



Thanks.

Upgraded to new modem and now slower speed or dropped connection on one laptop?
 
#2
If you have multiple other devices and laptops working fine, then it stands to reason that the issue is with the device that isn't working. It's network connection could be going bad, or it could be an older device that can't access the 5GHz channel while the others can and you actually have an issue with your 2.4GHz channel.
 
Top