Windows 10: Fast.com speed test shows high latency (any where from 300 - 900 ms) - Time Warner Internet

#1
This question is about "Windows 10: Fast.com speed test shows high latency (any where from 300 - 900 ms)", with Time Warner Cable internet and apps. I'm sure most here already know about fast.com. They are operated by Netflix, and have a neat feature that performs a loaded latency test (you can pick this for upload or download, download being the default).



Before the fix below, I had very high latency and my speed felt throttled on my Windows 10 PC.



After A BUNCH of research, I came across this:

https://support.microsoft.com/en-us/help/947239/description-of-the-receive-window-auto-tuning-feature-for-http-traffic



"If you enable Receive Window Auto-Tuning for WinHTTP traffic, data transfers over the network may be more efficient. However, in some cases you might experience slower data transfers or loss of connectivity if your network uses an older router and firewall that does not support this feature. For example, when you use Windows Internet Explorer to access applications that are hosted in Microsoft Office SharePoint Server, the HTTP traffic may slow down. This occurs because certain routers do not support the Receive Window Auto-Tuning feature.


Note

Since the release of Windows 7, Receive Window Auto-Tuning is now available for programs that use the Windows Internet (WinINet) application programming interface (API) for HTTP requests instead of WinHTTP. Some examples of programs that use WinINet for HTTP traffic include Internet Explorer, Outlook, and Outlook Express."



For some reason, Windows has chosen to enable screwy setting by default in Windows 10?!? No idea why as it hurt my machines performance even though I had all the usual windows settings like power manager optimized for high performance.



Some before and after speed tests are below. Loaded latency dropped from 600-800 ms to consistently under 35 ms. Speed is also MUCH more stable. Before it would fluctuate a lot.

All I sipmly performed these steps on the Windows 10 machine:

  1. Tap on the Windows-key, type cmd.exe, hold down Shift and Ctrl keys, and hit enter.
  2. Confirm the UAC prompt that opens.
  3. Run the command netsh interface tcp show global

That will then show the configuration options currently set. If “Receive Window Auto-Tuning Level” is set to normal, then run the following command to disable it:


netsh int tcp set global autotuninglevel=disabled

Hopefully this helps someone. I did also have a lot of issues with my Spectrum service, and the nice users here helped me debug some of that, so I though I'd share this.







Windows 10: Fast.com speed test shows high latency (any where from 300 - 900 ms)?
 
Top